Page 2 of 3

Re: Ordbot recommissioned

PostPosted: Thu Apr 02, 2015 8:53 pm
by cvoinescu
@Zebethyal: you're right, of course. I probably use my 3D printer less than you, and my filament is not nearly that cheap. I don't take any special precautions, though. The filament (which is not on a spool) just sits on the table behind the printer. Still, to clog my 0.4 mm nozzle, I'd need a 0.4 mm particle, and that's not dust -- that's sand, and not very fine sand at that. I doubt there's that much room between the filament and the PTFE liner, so I don't see how such a large particle could enter the hot end. And if the geometry of the chamber and orifice is reasonable, I'd expect any smaller particles to be dragged out by the molten plastic, rather than accumulate.

Anyway, my wife is going to embark on a venture that involves lots of 3D printing in PLA, so we're going to use the printer much more, and try cheaper filament too. We'll see how the J-Head fares then. :)

Re: Ordbot recommissioned

PostPosted: Sat Apr 04, 2015 2:12 am
by WillAdams
Well, I’ve got the Pico Hot End installed (may re-route the cables) and it’s printing quite nicely.

Re: Ordbot recommissioned

PostPosted: Sat Apr 04, 2015 10:41 pm
by WillAdams
Or, at least it was, until I seemed to have an extruder jam during a large print.

Got that cleared, and also slightly tightened one of the V-wheels on the X-axis which seemed loose.

For some reason now, the Y-axis is loosing steps. I’ve slightly increased the voltage (was at 1.1, now have it at 1.2).

It seems electrical, not mechanical, the sound is softer and less vibrant when it doesn’t move as far as it ought. I’ve checked and re-checked the connections. What else should I try?

Re: Ordbot recommissioned

PostPosted: Sat Apr 04, 2015 11:30 pm
by WillAdams
Upped the current again, and tried to tighten the pulley --- seems a bit better, though it lost steps on a positioning move, so a layer shifted on the current print.

Lessee, thinking aloud and trying to backtrack:

- destroyed a hot end, left machine idle until replacement arrived
- installed nifty new Pico hot end --- after a few minor hiccups, got it printing well w/ a makeshift fan shroud
- had the extruder jam during a long print, so rebooted and sliced it, then rebooted and tried printing it
- printing failed 'cause the Y-axis lost steps
- increased current to Y, decreased to X (not sure why I thought that last was a good idea)
- managed to print fan shroud
- installed it
- a different print failed 'cause the X-axis started slipping (see)
- increased the current to X
- Y-axis slipped again
- increased current (again), tried to tighten the belt for the Y-axis
- test print slipped during two positioning moves, seemed slightly over-extruded
- tried again --- seems to be printing fine

Anyone see anything egregious in the above? Hoping things are solved / working....


Re: Ordbot recommissioned

PostPosted: Sun Apr 05, 2015 12:00 am
by cvoinescu
It sounds good. I eyeballed the current on my ORD Bot-like machine to the point the steppers become warm after a few minutes. The belts as tight as I can get them with the tensioning system I have (slacken screws retaining idler mount, re-tighten while pushing belt taut with thumb).

The one thing that worries me is that increasing current on one axis seems to have a detrimental effect on the other axis -- unless that's you messing with more than one thing at a time. Is your power supply adequate?

Hopefully it will work smoothly for you from now on.

* * *

I have tried to express the idea that people who have a good understanding of a system (e.g. the printer electronics) have a better chance of getting it to work perfectly "out of the box", because they are aware of possible failure modes and work to avoid them, often in subtle ways and/or without being aware that they are doing so. This is knowledge that is often not visible to an observer. For instance, I know how to work relatively safely with ESD-sensitive parts without a wrist strap and an anti-static mat, but you may not notice my touching grounded surfaces to discharge stating charge before touching the parts, or my holding a finger in contact with the shroud of the USB connector while inserting the driver modules (in lieu of a grounded wrist strap), or my avoiding setting down the unpacked drivers on surfaces prone to static charge buildup. Someone else plugging a RAMPS and some Pololu drivers may end up with a fried Arduino or driver despite, superficially, doing the exact same thing that I did.

Nobody expressed this idea better than the author of this parable (attributed to Tom Knight). For context, a "LISP Machine" is a type of computer from the 70s (developed at MIT's AI Lab), and Knight is one of its inventors.
A novice was trying to fix a broken Lisp machine by turning the power off and on.

Knight, seeing what the student was doing, spoke sternly: "You cannot fix a machine by just power-cycling it with no understanding of what is going wrong."

Knight turned the machine off and on.

The machine worked.

Re: Ordbot recommissioned

PostPosted: Sun Apr 05, 2015 2:12 am
by WillAdams
Yeah, I need to check the power supply specs and run those numbers. Unfortunately, it’s attached to the machine in such a way that I can’t read the label. Project for tomorrow. That’s the change I was trying to consider, if the additional fan is drawing enough current to interfere w/ things.

Yeah, the Lisp machine story is funny — almost as good as the one about the unattached switch labeled magic and more magic. Can’t help but feel a special attachment to stories from that era, since one of my most vivid memories from childhood was Admiral Grace Hopper speaking to the high school when I was in 4th grade (fortunately, there was a special program allowing children to work at their grade level for science, math and English classes (with a 4 grade cap on advancement) so I was in an 8th grade class and got to attend).

All it took was a turn of a screw

PostPosted: Sun Apr 05, 2015 2:17 pm
by WillAdams
well, of the potentiometer.

When I went to dismount the power supply I noticed that there was a small control labeled:


Took a screwdriver to it, and the machine is finishing up a print pretty much perfectly.

Added this to the wiki: ... djustments

Re: Ordbot recommissioned

PostPosted: Mon Apr 06, 2015 12:06 am
by WillAdams
I put the voltage for X and Y back where it was and everything seems to be running fine again.

Re: Ordbot recommissioned

PostPosted: Sun Apr 12, 2015 12:26 pm
by WillAdams
And then it had problems, so I’ve cranked it up again.

Re: Ordbot recommissioned

PostPosted: Sun May 10, 2015 2:59 pm
by WillAdams
And it's still having problems, and its now started extruding into the air at the beginning of a print.

And it turned out I'd over-tightened the V-wheels w/ the nylon spacers --- fortunately had two matching aluminum ones --- replaced w/ those and added a pair of M5 washers and I'm back in business.